Install Needed YARN and Gulp Tools
All Varbase components are using Yarn, and Gulp to bring in number of development dependencies.
Make sure to install the following tools before any development.

Install sed and gawk

Helps with string replace and re-naming files.
1
sudo apt install -y sed gawk;
Copied!

Install npm and nodejs

Helps getting more development tools.
1
curl -sL https://deb.nodesource.com/setup_14.x | sudo -E bash -
2
sudo apt update
3
sudo apt install nodejs
4
sudo apt install build-essential
5
6
curl -L https://npmjs.com/install.sh | sudo -E bash -
7
sudo apt update
8
sudo apt install npm
Copied!

Install Yarn

1
sudo apt install yarn
Copied!
Install Yarn as a global by npm
1
sudo npm install -g yarn
Copied!

Install Gulp

Helps in managing tasks when compiling SASS/SCSS to CSS
1
sudo npm install gulp-cli -g
2
sudo npm install gulp -D
Copied!
Last modified 1mo ago